Status
Back
Maintenance
Update our internal systems
Completed 18 Jan at 12:00pm CET.
Affected services
Frontend
API
Completed
Maintenance completed
Posted 18 Jan at 12:00pm CET.
Started
We are updating our internal systems
Posted 18 Jan at 09:18am CET.